Skip to content

Development Environment


Development Tools


If you would like to build your own copy of Athenz rather than using the pre-built binary packages, then here is the list of development tools you need to have installed on your system.

Java Platform JDK 8


To build Athenz components, you must have Java Platform JDK 8 installed on your machine. The main authorization services - ZMS and ZTS, are written in Java and using embedded Jetty.

Oracle Java Platform JDK 8

Athenz has been developed and tested with Oracle Java Platform JDK 8. However, it should compile and run without any issues with OpenJDK 8 as well.

Maven


Download and install Apache Maven.

Git Client


If you don't have git client installed on your host, you can download one from Git website

Go


Install go by following the directions at Getting Started - The Go Programming Language.

Node JS


Install node by following the directions at Node.js JavaScript Runtime

Verify that you have the required minimum version of node and nodemon binaries installed on your system and are included in your runtime path:

$ node --version
v6.9.4
$ npm install -g nodemon
$ nodemon --version
1.11.0

Build Steps


To build Athenz components, change to the top level directory where Athenz code has been checked out and execute:

$ git clone https://github.com/yahoo/athenz.git
$ cd athenz
$ mvn clean install

The release packages will be created automatically in the assembly subdirectory.